install.php

  1. cis7 install.php
  2. cle7 install.php
  3. ecd7 install.php
  4. elmsmedia7 install.php
  5. harmony7 install.php
  6. icor7 install.php
  7. meedjum_blog7 install.php
  8. mooc7 install.php

Initiates a browser-based installation of Drupal.

Constants

Namesort descending Description
DRUPAL_ROOT Defines the root directory of the Drupal installation.
MAINTENANCE_MODE Global flag to indicate the site is in installation mode.

File

install.php
View source
  1. <?php
  2. /**
  3. * @file
  4. * Initiates a browser-based installation of Drupal.
  5. */
  6. /**
  7. * Defines the root directory of the Drupal installation.
  8. */
  9. define('DRUPAL_ROOT', getcwd());
  10. /**
  11. * Global flag to indicate the site is in installation mode.
  12. */
  13. define('MAINTENANCE_MODE', 'install');
  14. // Exit early if running an incompatible PHP version to avoid fatal errors.
  15. if (version_compare(PHP_VERSION, '5.2.4') < 0) {
  16. print 'Your PHP installation is too old. Drupal requires at least PHP 5.2.4. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information.';
  17. exit;
  18. }
  19. // Start the installer.
  20. require_once DRUPAL_ROOT . '/includes/install.core.inc';
  21. install_drupal();
Error | ELMSLN API

Error

×

Error message

  • Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/elmsln_community/api.elmsln.org/includes/common.inc:2791) in drupal_send_headers() (line 1499 of /var/www/html/elmsln_community/api.elmsln.org/includes/bootstrap.inc).
  • Error: Call to undefined function apc_delete() in DrupalAPCCache->clear() (line 289 of /var/www/html/elmsln_community/api.elmsln.org/sites/all/modules/apc/drupal_apc_cache.inc).
The website encountered an unexpected error. Please try again later.