function hook_wysiwyg_plugin

cis7 wysiwyg.api.php hook_wysiwyg_plugin($editor, $version)
cle7 wysiwyg.api.php hook_wysiwyg_plugin($editor, $version)
elmsmedia7 wysiwyg.api.php hook_wysiwyg_plugin($editor, $version)
icor7 wysiwyg.api.php hook_wysiwyg_plugin($editor, $version)
meedjum_blog7 wysiwyg.api.php hook_wysiwyg_plugin($editor, $version)
mooc7 wysiwyg.api.php hook_wysiwyg_plugin($editor, $version)

Return an array of native editor plugins.

Only to be used for native (internal) editor plugins.

Parameters

$editor: The internal name of the currently processed editor.

$version: The version of the currently processed editor.

Return value

An associative array having internal plugin names as keys and an array of plugin meta-information as values.

See also

hook_wysiwyg_include_directory()

7 functions implement hook_wysiwyg_plugin()

Note: this list is generated by pattern matching, so it may include some functions that are not actually implementations of this hook.

accessibility_wysiwyg_wysiwyg_plugin in sites/all/modules/ulmus/accessibility/modules/accessibility_wysiwyg/accessibility_wysiwyg.module
Implements hook_wysiwyg_plugin().
cis_service_icor_wysiwyg_plugin in sites/all/modules/elmsln_contrib/cis_connector/instance_data/cis_service_icor/cis_service_icor.module
Implements hook_wywiwyg_plugin().
ckeditor_link_wysiwyg_plugin in sites/all/modules/ulmus/ckeditor_link/ckeditor_link.module
Implementation of hook_wysiwyg_plugin().
footnotes_wysiwyg_wysiwyg_plugin in sites/all/modules/ulmus/footnotes/footnotes_wysiwyg/footnotes_wysiwyg.module
Implementation of hook_wysiwyg_plugin().
imce_wysiwyg_plugin in sites/all/modules/ulmus/imce_wysiwyg/imce_wysiwyg.module
Implements hook_wysiwyg_plugin().

... See full list

1 invocation of hook_wysiwyg_plugin()
wysiwyg_get_plugins in sites/all/modules/ulmus/wysiwyg/wysiwyg.module
Return plugin metadata from the plugin registry.

File

sites/all/modules/ulmus/wysiwyg/wysiwyg.api.php, line 38
API documentation for Wysiwyg module.

Code

function hook_wysiwyg_plugin($editor, $version) {
  switch ($editor) {
    case 'tinymce':
      if ($version > 3) {
        return array(
          'myplugin' => array(
            
            // A URL to the plugin's homepage.
            'url' => 'http://drupal.org/project/img_assist',
            
            // The full path to the native editor plugin, no trailing slash.
            // Ignored when 'internal' is set to TRUE below.
            'path' => drupal_get_path('module', 'img_assist') . '/drupalimage',
            
            // The name of the plugin's main JavaScript file.
            // Ignored when 'internal' is set to TRUE below.
            // Default value depends on which editor the plugin is for.
            'filename' => 'editor_plugin.js',
            
            // A list of buttons provided by this native plugin. The key has to
            // match the corresponding JavaScript implementation. The value is
            // is displayed on the editor configuration form only.
            'buttons' => array(
              'img_assist' => t('Image Assist'),
            ),
            
            // A list of editor extensions provided by this native plugin.
            // Extensions are not displayed as buttons and touch the editor's
            // internals, so you should know what you are doing.
            'extensions' => array(
              'imce' => t('IMCE'),
            ),
            
            // A list of global, native editor configuration settings to
            // override. To be used rarely and only when required.
            'options' => array(
              'file_browser_callback' => 'imceImageBrowser',
              'inline_styles' => TRUE,
            ),
            
            // Boolean whether the editor needs to load this plugin. When TRUE,
            // the editor will automatically load the plugin based on the 'path'
            // variable provided. If FALSE, the plugin either does not need to
            // be loaded or is already loaded by something else on the page.
            // Most plugins should define TRUE here.
            'load' => TRUE,
            
            // Boolean whether this plugin is a native plugin, i.e. shipped with
            // the editor. Definition must be ommitted for plugins provided by
            // other modules. TRUE means 'path' and 'filename' above are ignored
            // and the plugin is instead loaded from the editor's plugin folder.
            'internal' => TRUE,
            
            // TinyMCE-specific: Additional HTML elements to allow in the markup.
            'extended_valid_elements' => array(
              'img[class|src|border=0|alt|title|width|height|align|name|style]',
            ),
          ),
        );
      }
      break;
  }
}
Error | ELMSLN API

Error

×

Error message

  • Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/elmsln_community/api.elmsln.org/includes/common.inc:2791) in drupal_send_headers() (line 1499 of /var/www/html/elmsln_community/api.elmsln.org/includes/bootstrap.inc).
  • Error: Call to undefined function apc_delete() in DrupalAPCCache->clear() (line 289 of /var/www/html/elmsln_community/api.elmsln.org/sites/all/modules/apc/drupal_apc_cache.inc).
The website encountered an unexpected error. Please try again later.